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Inside InDesign: Text Wrap
Recipes for Applying—and
Ignoring—Text Wrap

Whip Up a Few Tasty Treats Using InDesign’s Text Wrap Features
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By DIANE BURNS
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t doesn’t take long to
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discover the useful������������������������������
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ness of InDesign’s
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Text Wrap feature.
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After all, text wrap is that lovely fea�������������������������������
ture that, among other things, allows
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our text to have a, shall we say, muy
��������������������
�����������������������
compatible relationship to adjacent
�������������������
graphics or even other text. Text
���������������
Wrap is simply applied by selecting a
frame or object around which you want text to wrap, then setting the desired wrap using
controls in the Text Wrap palette by choosing Window > Text > Text Wrap. Applying a text
wrap creates an editable text wrap boundary around an object.
The icons across the top of the palette indicate the
basic text wrap shape (Figure 1).
Once the basic shape is selected, you can set the inset
values, and in the case of Wrap Around Object Shape
, known as contour wrapping, you can also set the
text wrap boundary to be the same as the image’s clipping
path or alpha channel. Unlike in QuarkXPress, text wrap
in InDesign takes eﬀect regardless of the layering order
of objects.
However, even though text wrap can be essential to
Figure 1: Text Wrap palette
achieving a certain eﬀect, there are times when we need
text wrap around one area of an object, but not another.
For example, we might need body text to wrap around a graphic, but not a headline. That’s
when a little check box, located far away from the
Text Wrap palette, comes into play. This little text
wrap helper, Ignore Text Wrap, can be found at the
very
bottom of the Text Frame Options dialog box
Figure 2: Text Frame Options dialog (detail)
under Object > Text Frame Options (Figure 2). To use
this handy feature, select the frame containing the text that you don’t want to be aﬀected by
an overlying item that has Text Wrap applied, and check Ignore Text Wrap. With Text Wrap
and Ignore Text Wrap, you really can have it both ways. Use Ignore Text Wrap when you
want to create interesting pull quotes, headlines with graphics slightly overlapping them, or
even to put a price on your products! #
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Text Wrap is applied to the
graphic, causing the body text
to wrap around it.
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Ignore Text Wrap is applied to the frame containing the headline,
which would otherwise be pushed out of its frame.

Wrapped Graphics Over Text
Ingredients
1 Headline
1 Graphic
Body text to taste
The Text Wrap palette
The Text Frame Options dialog box

DIRECTIONS: Take one headline and one two-column frame of body
text; position on page. Place graphic. Apply text wrap to the graphic by clicking the
icon in the Text Wrap palette. Position the graphic over the text frames. The headline text
will momentarily be pushed out of its frame by the text wrap on the graphic; select the
headline text frame, open the Object > Text Frame Options dialog box, and click Ignore Text
Wrap. The headline will ﬂow back into its frame, and the graphic can be positioned over it
freely without displacing the text.
Serve chilled with garnish. Perfect with margaritas on the rocks.

Text Wrap à la New York Times
Ingredients
1 Capital letterform in your favorite font (e.g., Berthold City)
The Create Outlines command (optional)
The Text Wrap palette
The Text Frame Options dialog box

Text Wrap is applied to
the capital letter, causing
the body text to wrap
around it.
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DIRECTIONS: Type a capital letter in a text frame. Increase
size as desired. Optionally, you can convert the charac�������������
������������������������������������������
ter to outlines to make easier to work with: Click on the
�����������������������
frame with the Selection tool and covert to outlines using
the Create Outlines command. Create a separate text
frame containing the pull quote text, and apply text wrap
to the pull quote text frame by clicking the
icon in
the Text Wrap palette. Position the pull quote text within
the main story, and set the desired insets for the wrap.
Ignore Text Wrap is applied to the frame
Position the outlined capital within the pull quote and
containing the pull quote, which would
otherwise be pushed out of its frame by
main story. Apply text wrap to this frame. The pull quote
the text wrap applied to the capital letter.
text will momentarily be pushed out of its frame by the
text wrap on the capital; select the pull quote text frame,
open the Object > Text Frame Options dialog box, and click Ignore Text Wrap.
Serves thousands of readers every Sunday.
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Prix d’une Pêche
Ingredients
Body or other text
1 Image (e.g., a pretty peach)
Text for topping
The Text Frame Options or Preferences dialog box
DIRECTIONS: Take one image, and apply
Text Wrap is applied to the graphic, causing the body copy
text wrap to it by clicking the icon
in
to wrap around it.
the Text Wrap palette. Position the image
over text. Next, create a text frame that will
be positioned over the image. If you position the text frame over the image, the text
will be displaced by the Text Wrap applied
to the image. Instead, open the Text Frame
Options dialog box (Object > Text Frame
Options) and check Ignore Text Wrap. You
can now freely position the text over the
image, without displacing the topping text!
Ignore Text Wrap is applied to the frame containing the
If you’re putting the entire store on sale,
pricing text, which would otherwise be pushed out of its
you can save time by simply turning on
frame.
the Text Wrap Only Aﬀects Text Beneath
preference (InDesign > Preferences > Composition > Text Wrap). By this method, you don’t
have to use the Ignore Text Wrap option in each instance.
Use when you want the cool, refreshing pleasures of text sitting on top of an object to which
Text Wrap has been applied.
DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984. One of the ﬁrst
Macintosh-based design ﬁrms in the country, TechArt today is one of the leaders in print and web design,
specializing in East Asian languages. She is also the author of many books on publishing, and loves to cook.
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Inside InDesign: Paste Into
The Guilty Pleasures
of Paste Into

Paste Into creates a bounty of visual opportunities
By DIANE BURNS
ike most basic layout ingredients, the Paste
command is an essential workhorse, but it’s not
particularly appetizing on its own. After all, Paste
usually just places the contents of the clipboard in the
center of your document window. However, InDesign
oﬀers some variations on the Paste command—Paste in
Place and Paste Into—that yield a veritable feast of exciting
visual possibilities.
The Paste in Place command adds spice to Paste’s functionality in that it remembers the location of an object
Figure 1: Paste Into lets you position
that’s copied (or cut) into the Clipboard, and pastes it in the
grouped objects inside a frame.
exact same position, relative to the object’s location on the
spread. The nice thing about Paste in Place is that it lets you paste the Clipboard contents
on a diﬀerent layer, on a diﬀerent page in the same document, or on a page in a diﬀerent
document, while maintaining the position of the copied item.
But it’s the Paste Into command that can be the most enticing for the visual gourmand.
Paste Into, as its name implies, lets you paste the Clipboard’s contents inside, or
into, any frame or path, thus allowing the frame to act as a kind of mask for the
pasted object. The command works with any item created in InDesign, including
text, graphics, or grouped objects. In fact, using the Paste Into command is the only
way to get multiple items into a frame, which can be done by simply grouping the
items before copying them into the Clipboard (Figure 1). And while frames can act
as a mask for placed graphics (using File > Place), the Paste Into command allows
frames to act as a mask for text, too, an eﬀect that cannot be achieved by simply
placing text in a frame (Figure 2).
To use Paste Into in your kitchen requires two other pieces of information. If you Copy
an object to the Clipboard after ﬁrst selecting it with the Selection tool, both the content
and the frame will be pasted into the target frame. If you select the object with the Direct
Selection tool before copying, only the selection (the content or the frame) will be pasted.
Also, if the copied or cut object is not touching the target frame, the object’s upper lefthand corner is positioned at the upper left-hand corner of the target frame, similar to the
Place command. But if the copied object overlaps the target frame even a little, it behaves
like the Paste in Place command, by pasting the copied object inside the target frame in the
exact same position.
There are endless possibilities for special eﬀects you can cook up with Paste Into. Here
are a couple of our favorites for using Paste Into with text. #

L

Figure 2: You can mask
text by using the Paste Into
command. The text on the
left was copied and pasted
inside the circle on the right;
the circle acts like a window,
letting only a portion of the
text frame show through.
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Headline Noir et Blanc
Ingredients
1 letterform in your favorite font (e.g., Berthold City)
The Create Outlines command
The Paste in Place command
The Edit Paste Into command
The Direct Selection tool, for stirring
The headline text is
duplicated using the Paste
in Place command. The
copy has the color white
applied and is positioned
over the capital letter using
the Paste Into command.

DIRECTIONS: Type a capital letter in a text frame. Increase size as desired. Click on the
frame with the Selection tool and convert to outlines (Type > Create Outlines). Create the
headline text in a separate text frame, and position over the capital letter. Select the headline text with the Selection tool, and make a copy (Edit > Copy). Use Edit > Paste in Place to
create a duplicate of the text that is positioned over the original. Apply white (or color of
your choice) to the duplicated text, and Cut the duplicated text. With the Direct Selection
tool, click on the large capital letter, then use Edit > Paste Into to paste the white text inside
the letterform. Select the original headline text and use Object > Arrange > Send Backward
to position it behind the duplicate text. If you need to re-position the text, use the Direct
Selection tool to move the large capital letter, then group all elements.
Impressive in formal and casual settings alike!

Text in Puzzle Blocks
Ingredients
Several letterforms
The Create Outlines command
The Paste Into command
DIRECTIONS: This simple recipe is a real
crowd-pleaser. Type several letters, each
in its own text frame. Increase size and
apply color as desired. Draw several
frames (e.g., in the shapes of squares)
Letter blocks are created by copying
and apply various ﬁll colors. Select one of the individual
individual letters and using the Paste
Into command to position them inside
letters, and Edit > Cut (or Copy). Select one of the empty
rectangular frames.
frames and use Edit > Paste Into to put the letter inside
the frame. Select the letter inside the frame with the
Direct Selection tool, and position it freely within the frame.

Serve warm, or will keep several days on your hard drive, until required by client.
DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984. She has
authored several books on graphics software, including QuarkXPress and Illustrator. She loves to cook.
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Inside InDesign: Create Outlines
Outlines and
Compounds:
Creating Type Treats

Understanding compounds improves your success with text outlines

Figure 1: Certain elements that
can be part of text, such as
paragraph rules and underlines,
do not outline and disappear
altogether when Create
Outlines is applied.

Figure 2: Creating outlines
forms one compound path
per line.

By DIANE BURNS
The ability to convert text into outlines–editable paths that can mask images and other
objects–has been part of the digital recipe box for years, via Illustrator, QuarkXPress, and
a host of other applications. As you’d expect, InDesign’s Create Outlines command (Type
> Create Outlines) works similarly to Illustrator’s, but there are some important diﬀerences.
Understanding how InDesign’s text outlines form compound paths can be the key to successfully cooking up that delicious eﬀect you’re looking for.
With InDesign, unlike QuarkXPress, you don’t have to create outlines to achieve many
typographic special eﬀects; for example, you can stroke type or ﬁll type with a gradient
without creating outlines at all. But, if you want to change the shape of letters, or use letters
as a mask for an image, you’ll need to convert the text to outlines ﬁrst. One caveat to keep
in mind: InDesign lets you apply certain formats to type, such as underlines and paragraph
rules, that do not convert to outlines and will disappear when the text with which they are
associated is converted to outlines (Figure 1).
Converting text to outlines is simple: select the text you wish to convert and choose
Create Outlines (Type > Create Outlines). However, the exact results you’ll get depend on
how you select the text before choosing the Create Outlines command. There are three
options, each of which yields diﬀerent results. Selecting a text frame with the Selection
Tool converts all the text in the frame to outlines. Selecting text with the text tool converts
the text to outlines that are inline frames within the text frame. And ﬁnally, selecting text
with either tool and holding down the Option/Alt key while choosing Create Outlines preserves a copy of the text and creates outlines separately (often our favorite method).
You can’t go far with converting type to outlines without running into compound paths.
Created from two or more closed paths and used to add transparent holes to shapes or letters, compound paths are what puts the transparent circle in “O” and the half-moons in “B”
(these are called “counters”).
InDesign lets you create outlines of a single letter, several words, or even entire pages of
text. But note that it will make each line of text outlines its own compound path (Figure 2).
This aﬀects how images can be placed or pasted into the text outlines. For example, if you
try to place an image into multiple lines of text that have been converted to outlines, the
image will only appear in one line of text. To place the image in multiple lines of text, the
lines must ﬁrst be converted to one compound path. Or, let’s say you want to place diﬀerent
images into individual text characters. In this case, the compound path on the line must be
released to manipulate the characters individually. But this also releases the compounds on
individual characters and causes the counters to ﬁll in. No worries, because, as our recipe
shows, it’s easy to ﬁx. Now let’s go cook something up!#
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Appetizer: Opaque Counters
Find yourself with a letter lying around that you wish had an opaque
counter? The solution’s simple and eﬀective: convert the letter to
outlines, then select the counter with the Direct Selection tool and
ﬁll with Paper or other color as desired.

Image á la Mulit-line
Ingredients
1 multiple-line headline
The Create Outlines command
The Pathﬁner > Add command
In order to ﬁll multiple lines
of outlined text with one
image, make all the lines
one compound path using
the Add command (Object
> Pathﬁnder > Add).

DIRECTIONS: Type a headline of several lines in a text frame. Increase size as desired. Click
on the frame with the Selection tool and convert to outlines (Type > Create Outlines). With
the Direct Selection tool, de-select the text if necessary, then click on each line of text while
holding down the Shift key. With all the lines selected, create one compound path by using
the Add command (Object > Pathﬁnder > Add). Use the Place or Paste Into command to
position your favorite graphic within all the letters.
The beautiful simplicity speaks for itself!

Individual Images Roasted in Letterforms
Ingredients
1 headline word (or words)
The Create Outlines command
The Compound Paths Release command
The Compound Paths Make command
The Reverse Path command
DIRECTIONS: Select the frame containing the headline text
using the Selection Tool. Convert to outlines (Type > Convert
to Outlines). To separate the letters into individual paths, select
each line with the Direct Selection tool, and release the compounds (Object > Compound Paths > Release).
The transparent centers of letters with counters will ﬁll in, but each letter can be manipulated individually. To
rebuild the transparent centers of letter with counters, select each one with the Direct Selection tool, taking
care to select both the external path and the internal path, and make them compound paths again (Object >
Compound Paths > Make). Then select one point on the internal path and use the Object > Reverse Path command to knock the “hole” in the letter. M ove the individual letters or place images within, as desired.

Reﬁned results worth all the eﬀort!
DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984. She has authored several books on
graphics software, including QuarkXPress and Illustrator. She loves to cook.
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Inside InDesign: Paragraph Rules
Paragraph Rules:
Thinking Outside
the Box

Paragraph rules have ﬂexibility that can yield pleasant surprises
By DIANE BURNS
aragraph rules are one of those ingredients that many people just
don’t consider essential. After all, most paragraphs don’t have a
line above or below them, right? But wait—paragraph rules are
much more than the name implies. While they can be used to draw the
thin horizontal lines we usually think of as rules (Figure 1), they have a
lot more ﬂexibility. Paragraph rules can also be used to draw lines vertiFigure 1: Paragraph rules are
cally, create colored boxes behind text (Figure 2), and can even be applied usually the best way to apply
Figure 2: Next time you
ﬁnd yourself applying
above and below text to create the border of a box drawn around the text! horizontal lines within text.
color to a text box, think
What makes paragraph rules so ﬂexible is that you can set a rule to “draw” a rectangularof using a thick paragraph
based shape of almost any height and width. Select Paragraph Rules from the Paragraph palette
rule instead.
ﬂyout menu, and in the Paragraph Rules dialog box (Figure 3), set the desired height of the rule
(up to 1000 points) in the Weight ﬁeld, and adjust the width of the rule by setting the Width
pop-up menu (Text or Column) and optionally setting the Indents value
(up to +/- 720 points). The Oﬀset ﬁeld determines the starting point for
the rule above or below the text (up to 108 points). Remember you can use
the arrow keys within these ﬁelds, and be sure you have the Preview box
checked to view the results.
Think of Paragraph Rules as a simple sheet of rectangular-shaped paper
that can be very large or small. And because you can apply Rule Above and
Rule Below simultaneously, you essentially have two “sheets” of paper to
work
with. The only diﬀerence between a Rule Above and Rule Below is
Figure 3: The Paragraph
that a Rule Above is starts at the baseline of text and grows up when you increase the weight; a
Rules dialog box (OptionCommand-J).
Rule Below grows down. Rules always fall behind your text, and when applying both rules, the
Rule Above will always fall behind the Rule Below if the two overlap. Further adding to the fun
is that you can apply any type of custom stroke or color swatch, including gradients (Figure 4).
Of course, you can create the same eﬀects using other tools for drawing frames or lines, but
at times this is not desirable, since objects drawn with these tools will not stay anchored with
text as it is edited or moved. Not only do Paragraph rules stay with their associated text, but the
real beauty of them is they can easily be part of a Paragraph Style.
For all their ﬂexibility, there are limits to the usefulness of Paragraph
Rules; a “box” drawn around a one-line heading will need to have its
height adjusted for a two-line heading, for example. But the next time
you ﬁnd yourself repeatedly drawing lines or ﬁlling text frames with
color, think about pulling a Paragraph Rule or two out of your pantry.
Figure 4: Gradient swatches can be used to
Recipes on the next page will give you some ideas for getting started.#
create interesting Paragraph Rules.
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Box Me Up! Box Me Down!

Font: 11 pt Myriad Pro Light
Rule Above
Weight: 18 pts Color: blue
Width: Text Offset: -0p5
L Indent: -0p4 R Indent: -0p4

Ingredients
A list of text requiring numbering or bullets
The Paragraph Rules dialog box
A nested style for numbers or bullets
DIRECTIONS: To “draw” a frame around text using Paragraph Rules,
input values shown, or similar, in the Paragraph Rules dialog box. These
settings essentially create a Rule Above that is larger (by Weight and
Insets) than the Rule Below. The Rule Below is oﬀset to the middle of
the Rule Above, and the diﬀerence in size (Weight and Insets) is set to
the desired width of the box frame. The blue box holding the number is
set by the left indent. A nested style ﬁnishes the dish by formatting the
numbers and adjacent text.

Rule Below
Weight: 16 pts Color: Paper
Width: Text Offset: -1p
L Indent: 1p3 R Indent: -0p3

Streamlines production and gets you out of the kitchen fast!

Cascading Vertical Rules
Ingredients
Text headline requiring an adjacent vertical rule
The Paragraph Rules dialog box
Color swatch as desired

Font: 12 pt Myriad Pro Bold
Rule Below
Weight: 180 pts Color: red
Width: Column Offset: -0p9
L Indent: 0p0 R Indent: 13p10
(You could also use a Rule Above,
just change the offset.)

DIRECTIONS: This is a great way to draw vertical lines next to a heading
or other text, especially when the vertical lines are all required to be the
same length. You can use either a Rule Above or a Rule Below. Set the
Weight ﬁeld for the Rule to the height of the vertical line, and apply the
color desired. Then, set the right indent to the width of the text column
or box, less the width of the rule. Oﬀset the rule to align with the text.
Notice the rule can extend past other paragraphs below!
Impress friends and coworkers by keeping your vertical rules in order.

Delicious Dessert Fun!
Remember, you can use any stroke style, or
combination of stroke styles, for a paragraph rule. This includes gradients, and
special “Easter Egg” strokes: the dashes
Woof, Lights, Happy, and Feet, and the
stripe Rainbow

To access InDesign’s Easter Egg stroke
styles, create a custom style with the
name exactly as listed below.

Feet

Happy

Lights

Woof

Rainbow

DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984. She has authored several books on
graphics software, including QuarkXPress and Illustrator. She loves to cook.
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Inside InDesign: Blending Modes
Mixing It Up With
Blending Modes

A secret ingredient for results that surprise and delight.
By DIANE BURNS
lmost everyone is familiar with InDesign’s sexy transparency features, including Drop Shadows, Feathering, and the ability to change
an object’s opacity. But there’s another, less well-known way in which
transparency can be used in InDesign to great eﬀect: Blending Modes.
Available from a menu on the Transparency palette (Window > Transparency), innocuously labelled “Normal” by default, blending modes essenFIGURE 1: Blending modes on the
tially combine two colors to create a third color, or eﬀect. This capability
Transparency palette.
has long been available in Photoshop, but many InDesigners who aren’t
hands-on with Photoshop are likely unfamiliar with the great versatility of this feature in InDesign.
While they may seem confusing at ﬁrst, blending modes basically compare the color value of two
colors and use diﬀerent methods to combine them, depending on the mode chosen. The base color is
the underlying, or background color; the blend color, or foreground color, is the color of the selected
object on top; and the resulting color is the color produced by the blend. Like other transparency features,
blending modes are applied on an object, or frame level, and the frame may contain text, a vector graphic, or an image. To apply a blending mode, simply select an object or objects, then choose the appropriate blend mode from the pop-down menu on the Transparency palette (Figure 1).
Since each blending mode uses diﬀerent calculations to combine the background and foreground
colors, the results from each can be quite diﬀerent. Some modes tend to darken colors, such as Multiply, Darken and Color Burn. Others, including Screen, Lighten and Color Dodge, tend to lighten them.
There are many resources, including the InDesign Help ﬁles, that describe in detail the calculations that
occur when each blending mode is applied. But because the result of each blending mode depends on
the colors involved, the best way to see and understand the eﬀect of
each is to apply them one by one and see the result for yourself.
When you apply a blending mode to a group of objects and
position the group over another object, the eﬀect of the blending
mode applies to the objects beneath the group. If this is not what
The Overlay blending mode is applied to the type.
you’re going for, you can restrict which objects will be aﬀected
by the blending modes: select only the group of objects you wish
to be aﬀected, and turn on the Isolate Blending check box in the
Transparency palette. With Isolate Blending, the objects beneath
the group won’t be aﬀected by the blending modes in the grouped
objects (Figure 2).
Like all transparency eﬀects, if your ﬁle is ultimately going to
press, it’s important to work closely with your printer, and blending mode calculations in particular can aﬀect colors in unexpected
FIGURE 2: The background is affected by the blending mode (left), ways. But they’re great fun to work with, so next time you’re cookunless Isolate Blending is checked (right).
ing up a layout, try blending modes to add that special something.
We’ve provided two diﬀerent examples to get you started.#

A

The words “SEEING THROUGH THE” have Multiply applied, which produces
darker colors where the words intersect each other and the light gray
background boxes.

Mélange de Titre
Ingredients
1 headline or title
A patterned background
The Transparency palette
DIRECTIONS: Served up in
the Premier issue of InDesign
“CONFUSION” has Exclusion applied, which subtracts one color from another,
Magazine, this headline is just
depending on which has the greater brightness value. Similar to Difference,
one of a variety of ways blending modes
Exclusion produces results that are lower in contrast and more subtle.
can be combined for crowd-pleasing headlines. The steps are easy. First, create a text
headline, keeping in mind each word or group of words to which you wish to apply a diﬀerent blending
mode should be in a separate text frame. Position the headline over a patterned background. Select each
frame with the Selection Tool and apply a blending mode. Experiment with several, and see which works
best. Fonts of a heavy weight and simpler patterns tend to keep the result from getting too busy.
A little experimentation goes a long way!

Quick ‘N Easy Duotones
Ingredients
A color image
The Swatches or Color palette
The Direct Select tool
The Luminosity blending mode

A color graphic (top) is placed in a frame with a color ﬁll.
The graphic is selected and the Luminosity blending mode is
applied to produce a duotone effect (bottom).

DIRECTIONS: Place a color graphic on your page. Click on the
graphic and its frame with the Selection tool. Fill with a color
(in our example, we used red). With the Direct Selection tool,
click on the graphic to select it and apply the blending mode
Luminosity (Window > Transparency > Luminosity). Voila!
A nostalgic taste, without the trouble of going back in time.

DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984. She has authored several books on
graphics software, including QuarkXPress and Illustrator. She loves to cook.

Inside InDesign: Tables
The Table Subtle

Breaking out of the Rows & Columns mold
By DIANE BURNS
ny of us who have used InDesign’s table features know that they can make working with data in
rows and columns a downright pleasant experience. With alternating fills and stokes, the ability to
import Microsoft Word tables or Excel spreadsheets, and a host of other well-designed features, InDesign’s table features allow a creative touch to be added to the most mundane data or worksheet (Figure 1).
But in addition to dazzling displays of rows and columns, there
are other ways in which InDesign’s table features can be used to great
advantage. To make the most of the power and flexibility of the table
feature, it’s important to understand some of its basic characteristics.
First, a table is always contained inside a text frame. A table is always
edited with the Type tool. And a table is actually an inline frame.
Further, a table is unique in that a table cell is the only type of frame
in InDesign that grows as you type or add text to it!
These capabilities can be used in ways that aren’t always obvious
rows and columns. Because cells can be so easily split or merged,
almost any text in any kind of grid pattern within a layout can be
incorporated into a table. And it may seem obvious, but tables don’t have to
FIGURE 1: A typical table formatted
use any strokes between the cells, or any fill, for that matter, so they can be
using InDesign’s Table Option for
Alternating Fills. Rounded corners
useful for text or graphic objects that are just visually in alignment, but not
are achieved by copying the table
necessarily lined up in uniform rows and columns. Because table cells are so
and using the Paste Into command
easy to select, they are especially useful for text that gets changed frequently.
to position it within a frame with
rounded corners.
One common example is the slug information used at the bottom of advertisements and other layouts. Slug information is changed almost every time
it’s used, and tables make it much easier to edit than simply using a series of
text frames or worse, falling to the ills of using a complicated tabbing scheme
to achieve the same look (Figure 2).
Tables don’t even have to be made of multiple cells; a single
table cell is still a table. In fact, because of their ability to “grow”
as text is typed or added, one-cell tables can be the perfect
solution to layouts that require text to appear in boxes that are
shaded or stroked. Text in a table can be formatted just like any
other text, including applying Paragraph or Character styles,
and controls in the Table > Cell Options > Text dialog box allow
you adjust text insets, vertical alignment and the first baseline
position, similar to the Text Frame Options dialog box. With
this flexibility, the possibilities are endless!
The following recipes illustrate some of the ways in which
FIGURE 2: A slug that might be used by an advertising agency. All
the information that has to be input (boldface) sits in its own cell,
tables can expand your repertoire of InDesign dishes. #

A

so it’s easy to select and edit.

The Grid Hid
Ingredients
Text or title that falls in a visual grid
Table features
A frame with rounded corners (optional)
By placing this text in a table, the values that change
frequently are easy to update.

DIRECTIONS: Any time you have text that visually falls in a grid, you
can use a table. Formatting text using a table is especially useful
when you edit the text frequently, as in our example involving interThe table cells
revealed: The yellow
est rates. Start with the Table > Insert Table command, and create
tint highlights table
a table that is 2 columns by 3 rows. In the first column, merge the
cells that were merged
cells in Row 1 and 2. That cell holds the interest rate (“2.61” in our
to create one cell.
example). Next merge both cells in Row 3, which holds the last line
of text. Select the entire table, and remove all strokes: using the Cell
Options > Strokes and Fills command, set the weight of the strokes to 0. Format the text using Paragraph or Character
Styles if desired. For a finishing touch, create a frame with rounded corners. Tables themselves can’t have rounded corners, but there’s an easy workaround: draw a frame with rounded corners, then Copy or Cut the table and use the Paste
Into command to position it inside the rounded-corner frame.
Take the tedium out of a once tedious task!

Table for One, Please!
Ingredients
Layout with paragraphs that require a tinted box
or other special treatment
Table features
DIRECTIONS: This is great way to quickly highlight special paragraphs in
your layout by applying a tinted background or drawing a stroke around
them. First, select the paragraph or paragraphs you wish to give the
highlight treatment. Do not select the last paragraph’s ending Paragraph
Symbol. Use the Table > Convert Text to Table command to surround the
paragraphs with a table. Each paragraph will convert to a table cell, producing a one-column wide table. You can then use Table > Cell Options >
Stroke and Fill settings to give the cells a background or a stroke around
the edges. If you are highlighting multiple paragraphs, select the cells
containing each paragraph and use the Table > Merge Cells command to
create one table cell before you begin formatting. If you selected the last
Paragraph Symbol, you’ll end up with an extra row. Simply use the Table
> Delete > Row command to remove.

The highlighted paragraphs are single-cell tables.

Table for one has never been so much fun!
DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984 as one of the first Macintosh-based design firms in the
country. She has authored several books on graphics software, including QuarkXPress and Illustrator. She loves to cook.

Inside InDesign: World Languages
Adding a Foreign Flair:
World Languages

Variety is the spice of life!

Красная
площадь

By DIANE BURNS
or an easy way to add an exotic touch to your
layouts, try whipping up a few words or phrases
using the languages of far-away lands. InDesign—which,
along with OSX and WindowsXP, supports Unicode and
OpenType fonts—makes the once tedious process of adding non-English characters to your layout is as easy as un,
deux, trois...or 一、 二 、 三 、 as our friends in Asia
might say, er—write.
Even if you are using the English U.S. version of InDesign, you can work with a variety of languages. This is
largely due to InDesign’s support of Unicode, the character encoding system designed to include many languages
in one set of codes—as understood by a computer, that
is. Unicode-based OSX and Windows XP even include
many fonts for use with non-English languages. In addition, both InDesign CS and CS2 come with OpenType
fonts that also support many other languages, including a
full set of Japanese fonts, thus providing you with all the
ingredients necessary to give your design truly international appeal.
First some basics: Text—whether it’s French, Greek,
or Chinese—can come from a variety of sources, including MSWord, text or RTF ﬁles, or via the Clipboard.
FIGURE 1: OpenType fonts don’t all “speak the same
Before taking oﬀ on a foreign ﬂing, though, it’s important
language.” Garamond Pro (top) does not contain the Cyrillic
to understand that InDesign does not actually translate
glyphs needed for Russian, while Myriad Pro does (bottom).
English text into any other language. For the translation of
words, you need a machine or (preferably) human translator. In fact, if you’re going to handle even small
amounts of text, you need to have a native speaker available at some point in your workﬂow.
Once text is translated and ready for InDesign, the right font must be chosen. Not every font, even an
OpenType font, has characters, or glyphs, for every language, so it’s key to choose one that contains the
characters required by a language. Many European languages, such as French or Italian, use the same
characters as English, but other languages, such as Polish, Greek or Russian, require additional characters not used in English at all. The ﬁrst step in typesetting non-English text, then, is to make sure to use a
font that contains the glyphs for the language you’re working with. And, if a font is missing glyphs, you’ll
get the dreaded pink boxes (Figure 1). Simply change translated text to a font with additional glyphs
(Myriad Pro and Lucida Grande are good choices, among others), and the text will appear correctly.

F

If you’ve received translations in a text ﬁle that you need to
Place into your layout, there’s one other feature to be aware
of: Character Set encoding. Unfortunately, the whole world
doesn’t “speak” Unicode, so many text ﬁles are in an encoding
more or less speciﬁc to a particular language. But don’t worry,
it’s relatively easy to control: in the Place dialog box, turn on
Show Import Options. The top menu in the resulting dialog
box shows the encodings for diﬀerent languages (Figure 2).
Choose the one that’s appropriate for the text you want to place.
You’ll know if something’s amiss, because when the wrong
FIGURE 2: When importing text ﬁles, turn on Text Import
Character Set is chosen, the text will come in as “garbage” charOptions to make sure the character encoding matches the
language you’re importing.
acters that will not take on the correct appearance, regardless
of the font applied.
Be aware there are some languages that InDesign does not handle very well. For example, Middle Eastern
languages, such as Hebrew and Arabic, require special right-to-left composition and cannot be handled at all
by the English version of InDesign. For these languages, the Middle Eastern (ME) version is required.
Also, there are additional issues that arise when working with large blocks of text, such as correct hyphenation, spelling and, in the case of Asian text, line breaks. But for small amounts of text, the world is still your
oyster, and InDesign opens up a whole new world of possibilities, with an assortment of world languages
waiting for you to try. Don’t be afraid to experiment, and get to know your local language resources!#

Titre Dans le Japonais
Ingredients
1 headline or title in English
The same text, in Japanese*
Pinch of imagination
DIRECTIONS: Nothing says hip these days like things Japanese. From manga
comics to sushi, Japanese culture has inﬂuence and can be seen almost everywhere you go. It’s easy to add Japanese text to your layouts. Just be sure and
choose the right font, such as Kozuka or Hiragino, which can be found on
the font menu group listed below all your English fonts. Once the Japanese
font is applied, the Japanese text can be manipulated as you would any other
text—in other words, have fun!
ちょっと違うことをして友達を驚かせましょう!

(Surprise your friends with something diﬀerent!)

Springtime

SUMMER

Autumn
Winter

*:Japanese text can be found at many online sources, such as Sherlock’s Translation module, or on many web sites. Check with a native speaker, though, before incorporating
into your layout.

DIANE BURNS is a pioneer in electronic publishing, founding TechArt International in 1984 as one of the ﬁrst Macintosh-based design ﬁrms in
the country. Today TechArt is a leader in print and web design specializing in East Asian languages. She has authored several books on graphics
software, including QuarkXPress and Illustrator. She loves to cook.

InXXX: Pathfinder

Pathfinder Commands: Better Than Ginzu Knives!
These often-overlooked tools
can yield surprising results

By DIANE BURNS

Original shapes

Add: Combines all
selected objects into
one shape.

Subtract: Removes the
topmost shapes from
the bottom shape.

Intersect: Maintains
the area where objects
intersect.

Exclude Overlap:
Removes the area
where objects intersect.

Minus Back: Removes
the backmost shapes
from the top shape.

Figure 1: The basic Pathfinder operations.

Every good chef seems to have an assortment of
little gizmos and gadgets, designed for specific tasks,
that find their way to the back of a drawer and are
often forgotten about. Like those special tools, the
Pathfinder commands in InDesign are often either
forgotten about, or considered too sophisticated for
use by non-artistic types. Yet these series of icons
on the Pathfinder palette--or panel, in CS3--can slice
and dice and combine paths in unique ways that
add vastly to the repertoire of the InDesign chef.
When combined with InDesign’s other incredible
features for mixing up text and graphics, Pathfinder
can help you further push the creative edge. Yes,
they slice! They dice! And they’re practically FREEEE!
Like Illustrator, each InDesign Pathfinder option
creates compound paths in different compbinations,
often creating a “cookie-cutter” effect. As for their
basic operations, we’ve all seen countless examples
of simple shapes illustrating the effects, such as those
shown on left (Figure 1). Admittedly, these may not
be all that appetizing, and most of us rather move on
to another menu item. But when these functions are
applied more creatively to objects including images
and text, the results can be pleasantly surprising.
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Before applying Pathfinder commands to a more
interesting set of ingredients, there are a few basic
things you need to keep in mind. First, and obviously,
at least two objects must be selected. There is no
limit to the number of objects that can be selected
to become part of the new compound path, as
long as they are on the same spread. Next, applying
Pathfinder commands always changes the shape
of the selected objects, and that makes it a good
idea to copy the objects before applying Pathfinder
commands. Another basic thing to keep in mind is that
stacking order matters, since the commands work on
a topmost or backmost item in some pre-defined way.
Applying the Pathfinder commands will usually
cause the object to take on the attributes of the
topmost item, such as fill and stroke. The only
exception is the Subtract command, where the final
shape takes on the attributes of the backmost item.
As for the content, it depends on the nature of the
selected frames. When Pathfinder commands are
applied to text frames, only the shape of the frame
is usually affected, not the text itself. In order to alter
the text characters, first create a compound path
using text outlines, then apply one of the Pathfinder
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next page
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full screen
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InXXX: Pathfinder

commands. If a frame contains an image, it can
be deleted, depending on the selection and the
command, thus making it all the more useful to create
a copy of your selected objects before proceeding.
As mentioned, you can apply Pathfinder to
commands to multiple shapes, but they do not work
when the topmost items are grouped. They also do not
work with open paths, such as lines. Instead of a line,
though, you can use a really thin rectangle, like p.0001.
Experienced creative pros who have long been
familiar with Pathfinder commands in Illustrator
may wonder about the difference in using these
commands in one application vs. the other. It’s
true that the commands’ basic operations work the
same in both programs, but Pathfinder commands
in InDesign let you use these powerful tools in
conjunction with InDesign’s other capabilities for
combining text and graphics in powerful ways. On
the other hand, in Illustrator, the result of applying
Pathfinder commands is a live, editable object that
can be copied and pasted into Photoshop in an
editable form. In InDesign, the result is flattened.
Following you will find a couple of our
favorite recipes that use the most basic and
familiar Pathfinder commands, Add and Subtract.
Use them to mix up your own ingredients, and
may they inspire you to experiment on your
own with other Pathfinder commands to whip
up an abundance of delectable designs!

Inclinaison du Texte
Ingredients
1 frame of any shape or size
1 text frame, smaller is better
Text to fit
It’s easy to rotate a text frame to any angle. But what
if you want to maintain the frame position and rotate
the text inside the frame? Pathfinder to the rescue!
First, draw the frame that will be used to hold the
text; it need not be a text frame. Next, draw a small
text frame and type a small amount of text in it so
you can see the angle at which it will appear. Position
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the small text frame so it is on top of the first text
frame. Rotate it to the desired angle. Make sure the
small, rotated text frame appears completely inside
the larger frame. Select both shapes, and click on
the Pathfinder Add icon. Voila! Now you can place or
type any text you wish. You can resize or reshape the
containing text frame using the Direct Selection tool.
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Cookie-Cutters on Steroids
Ingredients
Your favorite image or images
1 series of paths or frames
Imagination to taste

One of the most interesting and powerful Pathfinder
commands is Subtract, which removes the topmost
objects from the back object. To create the examples
shown here, we used two slightly different approaches.
To create the first example, upper left, make a
series of lines using narrow rectangles and form them
in the pattern of a brick wall. Position the brick wall
pattern above the illustration. Select both the pattern
and the illustration and apply the Subtract command.
The image can be repositioned within the brick wall

pattern by selecting it with the Direct Selection tool.
To create the sample on the right, convert the text
you’ll be using to outlines (Shift-Command/Ctrl-O).
Move the outlines on top of a rectangle filled with
color, in this case yellow, then apply the Subtract
command. Position the resulting shape above images
as desired and the images will show inside the text
outlines. TIP: When using multiple lines of text outlines,
select each line using the Direct Selection tool and
Shift key before applying Pathfinder commands.
Diane Burns is an Authorized Adobe Instructor and president
of TechArt International. She is also a frequent contributor to
InDesign Magazine and speaker for the InDesign Conferences.
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InXXX: Anchored Objects

Anchored Objects: More Than Meets the Eye
Anchored Objects can be used
in ways that aren’t always so obvious

Figure 1:The
Anchored Object
dialog box has two
key control areas,
one for the object,
the other for the
position to which
you want the object
to anchor.

By DIANE BURNS
We all know that InDesign’s Anchored Object feature
can be useful. After all, the ability to position objects
that move with text is essential in certain layouts, and
can save hours of manual re-positioning. And since
InDesign CS2, anchored objects can be the more
familiar inline object, anchored to the baseline of text,
or can be moved anywhere on a page with custom
positioning.
Anchored objects are easy to create. Simply click
on any object using the Selection Tool. Cut or Copy the
object to the Clipboard, then click your text cursor
next to the text you wish to associate the object with,
and Paste. You can then use the controls in the
Anchored Objects dialog box to position the object
(Object > Anchored Object > Options).
The dialog box for custom positioning of anchored
objects can be a little intimidating at first, but it’s really
pretty straightforward. (Figure 1) In the top section of
the dialog box, choose the point on the object you
wish to use as a reference point. In the bottom section
of the dialog box, choose where you want the object
to be anchored, relative to the text or the page itself.
Also, take into consideration whether or not you have
Relative to Spine checked or not.

You can also just grab the object after it’s pasted
and position it visually. However, we’ve found this
doesn’t always set up the most efficient relationship in
the dialog box. It can be better to position the object
visually, and then open the Anchored Objects dialog
box to make sure the correct side of the object, and
where you’re anchoring it, is chosen.
Once you’ve set up the position of the anchored
object, the information can be stored as part of an
Object Style, making it easy to re-apply the settings.
And, if you lose track of where the object is anchored
to, simply turn on Show Text Threads; a dashed line will
appear from the Anchored Object to its anchor point.
The ability to anchor objects in a custom position
can be a very powerful production tool. Most of
us, though, think of this feature only in its classic
application, where images that need to run in a
margin alongside text are anchored to the appropriate
word, most commonly used in books and reference
publications of various kinds. However, there are
other, less obvious situations where the feature can
come in handy. We’ve whipped up a few examples
of these in the next pages to give you some ideas
of new ways to use this oft-forgotten feature.
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Lil’ Bits ‘o Fun
Ingredients
1 headline
1 set of Paragraph Rules, above & below
2 anchored shapes
1 chair to sit in, after viewing results!
This real-world recipe involves a trick with both
paragraph rules and anchored objects. The
publication has a heading at the top of every page,
and every couple of pages the heading changes.
The heading contains a box drawn around the text,
with two small dingbat squares on either side.
The box around the word is drawn with two
paragraph rules, of course, using the settings shown
here. Since InDesign allows the Rule Below to slide
under the text, but on top of the Rule Above, the two
can be combined to appear to draw a box around the
text (see Volume 1, Issue 4, February/March 2005 for
more cool tricks with Paragraph Rules). But the magic
that keeps the small dingbat characters attached
is achieved by making them Anchored Objects.
The dingbat characters are cut or copied into the
Clipboard, then pasted immediately in front of and
behind the text, thus anchoring them on either side of
the word. Once the dingbats are positioned correctly
you can double-click the word, edit it, and everything
is still perfectly lined up. Delicious!

Figure 2: Paragraph rules and anchored objects are
used to make this heading easy to edit.
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Setting a Splendid Table
Ingredients
Your favorite table of text or images, or both
Anchored object
Imagination to taste
This recipe comes from Michael Murphy, creator of
the excellent podcast, The InDesigner. It uses anchored
objects to give a really nice finish to tables. In the first
example shown, small triangles are created that are
the color of the adjacent cell. They are then anchored
to the beginning of the first word in the next cell,

and positioned to the left of the word. This way, it
appears the triangle is part of the previous cell.
In the second example, a similar technique is
used, this time employing a circle, again anchored
to the beginning of the first word in the cell, but
positioned down and to the left of the word, so
it falls in the intersection of the cells. In both of
these examples, an object style can be created that
sets the positioning correctly, or you can simply
select the object once it’s anchored and copy and

paste throughout the table. Try different shapes to
give the look you like best. Simply delectable!
In the final example, images are anchored to
the text in table headings. The nice thing about
this technique is if this row is set as a table heading
(Table > Convert Rows > To Header), the images
repeat, too, along with the text headings as the
table runs from frame to frame or page to page.
from the recipe box of Michael Murphy, The InDesigner
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Column Topper
Ingredients
An alphabetic list
Letters for column topping
Anchored Object options
The real key to thinking outside the box—or
frame—when working with anchored objects is
to understand the different orientations of your
layout an object can be anchored to. Most of us
think of anchoring an object to the edge of a text
frame, but you can also anchor an object relative to
a specific column, margin or even the page itself.
Because the settings give a lot of flexibility, it’s easy
to set up all kinds of anchor relationships that can be
big time savers. Here we show a simple alphabetic
list with headings at the top of each column where
name in the next letter begin. Because the heading
letters are anchored to a specific name, the letter
will travel appropriately, regardless of how the list
is edited (assuming, of course, the name to which
the heading letter is anchored is not deleted).
In fact, even if the list is changed to a
different number of columns, the headings
still line up, right where they’re supposed
to be. A tasty little topper, indeed!

Figure 3: Anchoring the column headings
keeps them in the correct position, even when
the number of columns is changed.

Diane Burns is an Authorized Adobe Instructor and president
of TechArt International. She is also a frequent contributor to
InDesign Magazine and speaker for the InDesign Conferences.
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Page Number Party Treats!

Here’s a little twist on an everyday feature that’s
sure to put a smile on your face
By DIANE BURNS

Figure 1: Insert a page marker on the Master Page to automatically
number document pages. The Section dialog box controls the page
number that appears on document pages, along with the number
style of the numbers, such as Arabic or Roman numerals.

Wingdings2 or other
picture/dingbat font

Text font of your choice

Figure 2: In this example, a picture
or dingbat font is used as the
background for page numbers.
Simply position the page number
marker formatted in the picture
font behind the marker formatted
in a regular text font. If some of the
pictures are not aligned when they
appear on document pages, release
them from the Master Page and
reposition the picture font, leaving
the page number in a consistent
position.

Even the most serious chef needs to have fun
sometimes, and sometimes the most common
everyday ingredients can be the most fun of all. Take
automatic page numbering, for example. Page
numbering is one of those little things in our layout life
that is very necessary, but not something we really get
very excited about.
The feature is easy to use: On the Master Page of
your document, insert the special marker for a page
number (Type > Insert Special Character > Markers >
Current Page Number) , then format the marker text
using any text attributes you would normally apply. On
the Master Page, the marker will display the Master
Page prefix (usually “A” for the first Master Page), but
on the document pages, the actual page number will
display, starting with “1” as the default.
Next, set the page numbers that will appear—and
whether a facing-page document’s starting page is on
the left or right—by clicking on the document page
icon in the Pages Panel, then using controls in the
Sectioning dialog box (Pages panel > Numbering &
Section Options), shown in Figure 1.
Not exactly fun so far, right? But there are a couple
of twists that can put the sprinkles on top of this little

cupcake. What if you format the page number marker
as a picture or dingbat font? Well, you’d have a
different picture on every page! Add to that the fact
you can have multiple page markers on any given
page, and that means that one or more markers can be
pictures, while another marker can still give you page
numbers on all your document pages (Figure 2).
Crazy, huh? But that’s why it’s fun! Try different
effects and type treatments for the dingbat or picture
font, and you can get some really interesting results.
And there are some very nicely designed picture fonts
available, many of them for free.
There are a couple of caveats that require a
workaround. One is that some picture fonts do not
include any characters for numbers, and another is
that you may end up with two pictures if your document exceeds 10 pages.
We’ve included a couple of recipes on the following
pages to get you started, along with some workarounds and things to watch out for. We hope they will
give you the idea, and with a little imagination, you’ll
find the possibilities are limitless. Feel free to email us
samples of what you come up with, and most of all—
enjoy!
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Big & Bold
Ingredients
1 multiple-page document
1 large page number marker
1 picture or dingbat font
This technique has so many possibilities! Start on the
Master Page of your document. Draw a large text
frame that fills the entire page. Insert the marker for
Current Page Number, and format it with your favorite
picture or dingbat font, in a large size. Our example to
the right (Figure 3) uses 567-point Webdings.
One thing to be aware of when working with page
number markers is that the containing text frame must
be much larger than you’d have for a normal text
character. After all, on document pages, the frame may
need to accommodate numbers that are more than
one digit. The page marker’s text frame in our example
extends well beyond the edge of the page in order for
the font character to fill the page. Also, make sure the
edge of the marker’s text frame does not extend over
the spine, or the same character will appear on both
left and right pages.
Finally, as we mentioned, some fonts do not have
characters for numbers, including some shown in our
examples here. To get around this, use the Numbering
& Section Options dialog box to format the numbers
as A, B, C, D instead of 1, 2, 3, 4. If you want regular
page numbers also, you’ll have to type them in
manually, because Numbering & Section Options is a
page-level attribute. Add a text frame for this on the
Master Page, though, so the numbers appear in the
same location on every page. Gorgeous!

Figure 3: In these
examples, a picture or
dingbat font is used as a
full-page background for
each page. The containing
text frames for the page
number marker are much
larger than the page, and
the marker is aligned to the
spine on each master page.
The resulting document
pages are shown here.

Webdings

MiniPics Digidings

Counterscraps
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The master pages shown to the left
and right have page number markers,
formatted in various dingbat and
picture fonts, that are Pasted Into other
frames. Vivid colors are shown here to
make the example clearer, but all could
be screened back to provide a page
background. The example far right
positions the page markers on a text
path.

Tons o’ Teeny Tiny Treats
Ingredients
1 dozen, more or less, picture or dingbat fonts
Paste Into command
A pinch of imagination
Why stop with one fun font per page? The more the
merrier! Use a variety of picture or dingbat fonts
applied to multiple page markers on your master
pages, and let the fun begin!
We’ve used a couple of different approaches
in the samples here. To create our first two
examples, above left, create a text frame with the
page number marker formatted in a picture font.
Draw separate frames, creating a grid, or creating

frames with rounded corners. Next, copy the page
number marker and the use the Edit > Paste Into
command to position the marker inside the frame.
Our final crazy example uses text on a path.
Format the page number marker in a picture font.
Create the path using the pencil tool, and draw
a spiraling line. Select the page number marker,
then click on the path with the Type on a Path tool.

Paste the page number marker, then press the Tab
key and paste again. Finally, use Type on a Path
options (Type > Type on a Path > Options) to Skew
the page number markers. Crazy, baby, crazy!
Diane Burns is an Authorized Adobe Instructor and president of
TechArt International. She is a frequent contributor to InDesign
Magazine and speaker at MogoMedia’s InDesign Conferences.
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